re = /(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})/m
str = 'PJSIP/117-AA01002-00000039
SIP/117-AA01002-00000039
SIP/1030-AA01002-00000039
PJSIP/10301-AA01002-00000039
Local/DIAL-8297225031@fromotherpbx-0000004e;2
Local/132-54-0@dialfromfollowme-00000022;2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end