use strict;
my $str = 'PJSIP/117-AA01002-00000039
SIP/117-AA01002-00000039
SIP/1030-AA01002-00000039
PJSIP/10301-AA01002-00000039
Local/DIAL-8297225031@fromotherpbx-0000004e;2
Local/132-54-0@dialfromfollowme-00000022;2';
my $regex = qr/(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}