import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "File\\s\\'(?<pathname>.+[\\/\\\\])(?<filename>[^\\\\\\/]+)\\'\\schecksum\\schanged\\.";
final String string = "File '/apps/data/db.data' checksum changed.\n"
+ "File 'c:\\windows\\system32\\xpsservices.dll' checksum changed.\n"
+ "File 'C:\\filename\\with\\space in it.txt' checksum changed.\n"
+ "File '/test /of space/inpath.txt' checksum changed.\n"
+ "File '/test/of/ßàdSpecial/characters in path' checksum changed.\n"
+ "File 'ß:\\weirdhaving/abetacharacter/drive.name' checksum changed.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}