// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)File\s\'(?<pathname>.+[\/\\])(?<filename>[^\\\/]+)\'\schecksum\schanged\.").unwrap();
let string = "File '/apps/data/db.data' checksum changed.
File 'c:\\windows\\system32\\xpsservices.dll' checksum changed.
File 'C:\\filename\\with\\space in it.txt' checksum changed.
File '/test /of space/inpath.txt' checksum changed.
File '/test/of/ßàdSpecial/characters in path' checksum changed.
File 'ß:\\weirdhaving/abetacharacter/drive.name' checksum changed.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}