import Foundation
let pattern = #"File\s\'(?<pathname>.+[\/\\])(?<filename>[^\\\/]+)\'\schecksum\schanged\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
File '/apps/data/db.data' checksum changed.
File 'c:\windows\system32\xpsservices.dll' checksum changed.
File 'C:\filename\with\space in it.txt' checksum changed.
File '/test /of space/inpath.txt' checksum changed.
File '/test/of/ßàdSpecial/characters in path' checksum changed.
File 'ß:\weirdhaving/abetacharacter/drive.name' checksum changed.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)