re = /File\s\'(?<pathname>.+[\/\\])(?<filename>[^\\\/]+)\'\schecksum\schanged\./m
str = 'File \'/apps/data/db.data\' checksum changed.
File \'c:\\windows\\system32\\xpsservices.dll\' checksum changed.
File \'C:\\filename\\with\\space in it.txt\' checksum changed.
File \'/test /of space/inpath.txt\' checksum changed.
File \'/test/of/ßàdSpecial/characters in path\' checksum changed.
File \'ß:\\weirdhaving/abetacharacter/drive.name\' checksum changed.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end