$re = '/([][^\\\\./-])(?=.*\1)/m';
$str = './[\\folder]/this-is-a.test/fi^le.cxx.LAST[]^\\/-.h';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;