re = /([][^\\.\/-])(?=.*\1)/m
str = './[\\folder]/this-is-a.test/fi^le.cxx.LAST[]^\\/-.h'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result