import re
regex = re.compile(r"([][^\\./-])(?=.*\1)", flags=re.MULTILINE)
test_str = "./[\\folder]/this-is-a.test/fi^le.cxx.LAST[]^\\/-.h"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)