#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b\w?Hello\w?\b"
Local $sString = ""Hello, my friend" = false (which I want to be true) " & @CRLF & _
""Hello." = false (which I want to be true) " & @CRLF & _
"Hellomyfriend" & @CRLF & _
"Hello my friend" & @CRLF & _
"dhellod my phellow" & @CRLF & _
"1hello1 not 22hello22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")