using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w?Hello\w?\b";
string input = @"""Hello, my friend"" = false (which I want to be true)
""Hello."" = false (which I want to be true)
Hellomyfriend
Hello my friend
dhellod my phellow
1hello1 not 22hello22";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}