$re = '/\b\w?Hello\w?\b/mi';
$str = '"Hello, my friend" = false (which I want to be true)
"Hello." = false (which I want to be true)
Hellomyfriend
Hello my friend
dhellod my phellow
1hello1 not 22hello22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);