import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w?Hello\\w?\\b";
final String string = "\"Hello, my friend\" = false (which I want to be true) \n"
+ "\"Hello.\" = false (which I want to be true) \n"
+ "Hellomyfriend\n"
+ "Hello my friend\n"
+ "dhellod my phellow\n"
+ "1hello1 not 22hello22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}