use strict;
my $str = '"Hello, my friend" = false (which I want to be true)
"Hello." = false (which I want to be true)
Hellomyfriend
Hello my friend
dhellod my phellow
1hello1 not 22hello22';
my $regex = qr/\b\w?Hello\w?\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}