// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b\w?Hello\w?\b").unwrap();
let string = "\"Hello, my friend\" = false (which I want to be true)
\"Hello.\" = false (which I want to be true)
Hellomyfriend
Hello my friend
dhellod my phellow
1hello1 not 22hello22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}