const regex = /\b\w?Hello\w?\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\w?Hello\\w?\\b', 'gmi')
const str = `"Hello, my friend" = false (which I want to be true)
"Hello." = false (which I want to be true)
Hellomyfriend
Hello my friend
dhellod my phellow
1hello1 not 22hello22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}