using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*((^|\W)(ne)(\W|$)).*";
string input = @"ne nado mne
da,mne,horosho
ne
eto bylo ne
da,ne,horosho
da mne eto nerо yo!!!!ne nado
nado!!!none mne
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
olohon nado!!!!ne!eto
fac eto ploho.ne,ploho
da ne nado";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}