# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*((^|\W)(ne)(\W|$)).*"
test_str = ("ne nado mne\n\n"
"da,mne,horosho\n\n"
"ne\n\n"
"eto bylo ne\n\n"
"da,ne,horosho\n\n"
"da mne eto nerо yo!!!!ne nado \n\n"
"nado!!!none mne \n\n"
"hey.mne ne nado\n\n"
"hai eto ploho.neploho\n\n"
"olohon nado mne eto\n\n"
"olohon nado!!!!ne!eto\n\n"
"fac eto ploho.ne,ploho\n\n"
"da ne nado")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.