import Foundation
let pattern = #".*((^|\W)(ne)(\W|$)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ne nado mne
da,mne,horosho
ne
eto bylo ne
da,ne,horosho
da mne eto nerо yo!!!!ne nado
nado!!!none mne
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
olohon nado!!!!ne!eto
fac eto ploho.ne,ploho
da ne nado
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)