re = /.*((^|\W)(ne)(\W|$)).*/m
str = 'ne nado mne
da,mne,horosho
ne
eto bylo ne
da,ne,horosho
da mne eto nerо yo!!!!ne nado
nado!!!none mne
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
olohon nado!!!!ne!eto
fac eto ploho.ne,ploho
da ne nado'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end