const regex = /.*((^|\W)(ne)(\W|$)).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*((^|\\W)(ne)(\\W|$)).*', 'gm')
const str = `ne nado mne
da,mne,horosho
ne
eto bylo ne
da,ne,horosho
da mne eto nerо yo!!!!ne nado
nado!!!none mne
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
olohon nado!!!!ne!eto
fac eto ploho.ne,ploho
da ne nado`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}