import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*((^|\\W)(ne)(\\W|$)).*";
final String string = "ne nado mne\n\n"
+ "da,mne,horosho\n\n"
+ "ne\n\n"
+ "eto bylo ne\n\n"
+ "da,ne,horosho\n\n"
+ "da mne eto nerо yo!!!!ne nado \n\n"
+ "nado!!!none mne \n\n"
+ "hey.mne ne nado\n\n"
+ "hai eto ploho.neploho\n\n"
+ "olohon nado mne eto\n\n"
+ "olohon nado!!!!ne!eto\n\n"
+ "fac eto ploho.ne,ploho\n\n"
+ "da ne nado";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}