use strict;
my $str = 'ne nado mne
da,mne,horosho
ne
eto bylo ne
da,ne,horosho
da mne eto nerо yo!!!!ne nado
nado!!!none mne
hey.mne ne nado
hai eto ploho.neploho
olohon nado mne eto
olohon nado!!!!ne!eto
fac eto ploho.ne,ploho
da ne nado';
my $regex = qr/.*((^|\W)(ne)(\W|$)).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}