using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:.*?,){3})[^,]*,(.*)$";
string substitution = @"$1$2";
string input = @"a,b,c,d,e,f
g,h,i,asj,k,l";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}