const regex = /^((?:.*?,){3})[^,]*,(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:.*?,){3})[^,]*,(.*)$', 'gm')
const str = `a,b,c,d,e,f
g,h,i,asj,k,l`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);