use strict;
my $str = 'a,b,c,d,e,f
g,h,i,asj,k,l';
my $regex = qr/^((?:.*?,){3})[^,]*,(.*)$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";