re = /^((?:.*?,){3})[^,]*,(.*)$/m
str = 'a,b,c,d,e,f
g,h,i,asj,k,l'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result