use strict;
my $str = '020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001';
my $regex = qr/-0+([1-9]\d*)$/mp;
my $subst = '-$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";