// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-0+([1-9]\d*)$").unwrap();
let string = "020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001";
let substitution = "-$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}