import Foundation
let pattern = #"-0+([1-9]\d*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)