$re = '/-0+([1-9]\d*)$/m';
$str = '020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001';
$subst = "-$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;