#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)("\w.[^\\]+)\\n ?"
Local $sString = "\n "this is some text \n this should not be on the new line" \n "asdflksd sdflk \n sdafsdf""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)