using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""\w.[^\\]+)\\n ?";
string substitution = @"\1";
string input = @"\n ""this is some text \n this should not be on the new line"" \n ""asdflksd sdflk \n sdafsdf""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}