re = /("\w.[^\\]+)\\n ?/m
str = '\\n "this is some text \\n this should not be on the new line" \\n "asdflksd sdflk \\n sdafsdf"'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result