$re = '/("\w.[^\\\\]+)\\\\n ?/m';
$str = '\\n "this is some text \\n this should not be on the new line" \\n "asdflksd sdflk \\n sdafsdf"';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;