// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("\w.[^\\]+)\\n ?"#).unwrap();
let string = "\\n \"this is some text \\n this should not be on the new line\" \\n \"asdflksd sdflk \\n sdafsdf\"";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}