# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_/$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_/gm;t' <<< "021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
"