// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_").unwrap();
let string = "021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
";
let substitution = "$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}