#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_"
Local $sString = "021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)