import Foundation
let pattern = #"(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)