using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_";
string substitution = @"$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_";
string input = @"021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}