use strict;
my $str = '021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
';
my $regex = qr/(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_/mp;
my $subst = '$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";