$re = '/(?i)^(.*?)_(\d{6}\D*\d{4})_(\d+)_(od|sd)_/m';
$str = '021-05-05_10-10-12-111_Nancy_Test_123456-1234_194456454390816_OD_2021042911270.pdf
';
$subst = "$2_servername1_$4_yyyy_mm_dd_ss_$1_$3_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;