# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^:\w]|\A)n\(\)/$1dplyr::n()/gm;t' <<< "n()
n()
a = n()
b = runif(n())
function()
dplyr::n()"