// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^:\w]|\A)n\(\)").unwrap();
let string = "n()
n()
a = n()
b = runif(n())
function()
dplyr::n()";
let substitution = "$1dplyr::n()";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}