const regex = /([^:\w]|\A)n\(\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^:\\w]|\\A)n\\(\\)', 'gm')
const str = `n()
n()
a = n()
b = runif(n())
function()
dplyr::n()`;
const subst = `$1dplyr::n()`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);