$re = '/([^:\w]|\A)n\(\)/m';
$str = 'n()
n()
a = n()
b = runif(n())
function()
dplyr::n()';
$subst = "$1dplyr::n()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;