using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^:\w]|\A)n\(\)";
string substitution = @"$1dplyr::n()";
string input = @"n()
n()
a = n()
b = runif(n())
function()
dplyr::n()";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}