#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,4}[_].*"
Local $sString = "1234_test.mp3" & @CRLF & _
"999_test.mp3" & @CRLF & _
"12_test.mp3" & @CRLF & _
"0_test.mp3" & @CRLF & _
"0t_est.mp34" & @CRLF & _
"t_est1234.mp3" & @CRLF & _
"@_test.mp3" & @CRLF & _
"/_test.mp3" & @CRLF & _
"\\_test.mp3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")