import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,4}[_].*";
final String string = "1234_test.mp3\n"
+ "999_test.mp3\n"
+ "12_test.mp3\n"
+ "0_test.mp3\n"
+ "0t_est.mp34\n"
+ "t_est1234.mp3\n"
+ "@_test.mp3\n"
+ "/_test.mp3\n"
+ "\\\\_test.mp3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}